Bash Script to Determine Terrorist Threat Level

I’ve really been immersing myself into the world of Bash scripting lately. There is an incredible amount of productivity-increasing scripts available online, and I have already written several of my own that make my programming life just a little easier.

That said, I have also come across quite a few pointless but entertaining scripts, such as this one which detects the current “terrorist threat level” as determined by the U.S. Department of Homeland Security.

The script is all on one line, but I broke it up for display purposes:

This reminds me of two things: (1) how powerful scripting is and (2) how absurd the idea of a “threat level” is in the context of the politicization of the “war on terror”.

Leave a Reply

Your email address will not be published. Required fields are marked *